Microsoft FrontPage 2003 Tutorial (Basic)

Welcome to the online tutorial for using Microsoft's FrontPage 2003 to create a personalized
webpage!
In the ten easy steps below you will become familiar with the process of using FrontPage, an
HTML editor that lets you design webpages easily and quickly with a great deal of creative
control.

the prerequisites...

To be able to complete this tutorial you will need the following:
e a computer with Internet access and FrontPage 2003
Prior to beginning this tutorial you should be able to perform the following basic tasks on your computer:

* Be able to turn on the computer

* Be aware of basic navigation using the keyboard and mouse

« Know the meanings of some basic computer terms

* Locate 'Start' on the desktop and be able to navigate to the desktop
* Be able to open programs by using the mouse and clicking

* Be able to use a search engine such as Google

* Be able to select text and graphics by highlighting

the steps..
' step one Step One [Create and name a folder on the desktop
f___ft’_e_f?_'_ﬂf_‘_?__ Step Two |Open FrontPage and create a new blank page
|  step three Step Three |Rename the webpage and save it in a folder on the desktop
| step four Step Four |Choosing the background of the page and view in a browser

|

]

|
I ]
| stepfive | Step Five |Inserting and modifying a table
| [stepsix |

|

]

]

|

5t=ep 5ix Step Six Modifying cells
| step seven Step Seven |Modifying font
| step erght Step Eight |Inserting and modifying graphics
| step nine Step Nine |Creating hyperlinks
[ Istepten Step Ten [Create the page

advice before starfing...

Before you begin, two words of advice that cannot be stated often enough while doing a computer project...
Word One: SAVE EARLY, SAVE OFTEN to avoid losing your page and its revisions!!!

Word Two: If you do not like the changes, 'Ctrl' and 'Z' simultaneously to undo or...
on the toolbar, go to 'Edit' > 'Undo' to undo the changes

(Edit | Miew Insert  Format  Teol
i) [ Undo Edit Properties  Chrl+Z
il Gt B o T el W

Now, time to begin!

W3HUB PTE LTD Page 1 2/24/2006



Step One

In this step you will use the right mouse button to create a new folder on your Desktop and you will then
rename the folder to reflect the project on which you are working.

1. Right click anywhere on the Desktop to open the menu

Arrange Icons By L4
Refresh

Paste
Paste Shortout
Indao Move Chrl+Z

Mew 4

niew Properties
MYEeystone k

Properties

2. Go to 'New' > 'Folder' to create a new folder on the desktop and click on it

m Shorkout

niiew Properties
My eyskone 4 & Bricfease

3. Right click on the folder and rename the folder 'biography' to reflect the project on which you are working

4. From this point on, save everything you create for this project in this folder

top | steps
Step Two

In this step you will use the 'Start' button to open FrontPage and create a new blank page.

1. Click on the 'Start' button in the lower left of your computer screen

2. Go to 'All Programs' > 'Microsoft Office' > 'Microsoft Office FrontPage 2003' and click
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ﬁi’ Micrasaft Office Microsoft Office Toaols k

Ca Microsoft Office Access 2003
[@ Microsoft Office Excel 2003

J"f] Metscape 7.1 4
[F) MVIDIA Corporation 3

lrj POY-Ray For Windows «3.5 4 E Microsoft Office FrontPage 2003

'J'jj PowerQuest Drive Image 7.0 r :_\_,'l Microsoft Office Chitlook 2003

3. Once FrontPage opens, click on the 'New Page' icon to create a new page in FrontPage

File Edt Wiew Insert

=R
Verdana -
== Create a new normal page|

4. The new page should have a tab that has the heading 'new_page_1.htm'

ades Rt jnew_page_l.hl:m
<hody >/ ['\\S

I <html>

1 <head>

<meta nane="GENERATOR™ content="Microsoft FrontPage 6.0

»<meta name="Progld”" content="FrontPage.Editor.Document’ =

Gremeta http-equiv="Content-Type' content="text/html; charset=windows-1252">
T LtitlexNew Page l</title:

& < heads

e

L hodys

12 B /hodys

top | steps

Step Three

In this step you will rename the new blank page you created in FrontPage and save it in the folder you have
created on the Desktop.

1. Go to 'File' > 'Save As...'and click to open the window
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%] Microsoft FrontPage

o

R by iz
-
=

Edit  Wiew

Inse bt

open..,  Chl+0

Open Site. .,

Cinse Sike

Save ChrlS

Save As. .,

[

Ea D G

Save all

File Search...

iy

2. Use the pulldown menu to navigate to your 'biography' folder on your Desktop and click on it

Save i

@ Deskkop

3. When the window pops up, select the 'Change title...' button and title your page whatever you want

My Documents

‘¢ Sabrina's Computer

--; ([ Deskiop

My Recent
Documents

¥
©,
Deskiop

2

L

{3 Sabrina's Documents
i Shared Documents
‘ﬂ 314 Floppy (A:)
G2 HP_PAYILION (20
¥ MSM_SETUR (D1
.k, DD Drive (E:)
\_r} My Mebwork Places
-7‘,_} My Documents
[5) backgrounds
SR Dinaraphy:
[y camp logan %
[0y computer and website stuff
[y entertainment stuff

(I titled mine 'Sabrina's Autobiography Page')

Click on the 'File name:' window and name your page 'bio.htm'

Click on the 'Save' button
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Save As

Save in:

| |53 biography

v|@'@|ﬁxt_{@*hnlﬁv

€

£

.

-—

Places

My Recent
Diocurments

Deskbop

My Documents

My Computer

Iy Mebwork.

Page title:

Sabrina's Autobiography Page

Change kitle. ..

File narre: it.i.;.,htm

#

[, Save ]

Save as bype: i'-.-'-.-'el:u Pages

%)

Zancel I

Step Four

top | steps

In this step you will choose the background of your page and then view the page in a browser window.

1. Right click anywhere on the 'bio.htm' page to pull up the menu

2. Go to 'Page Properties...' and click

By <o

= Copy

@ Paste

Cpen Page in Mew Window

Miosee Split

fgh: Manage Editable Regions. ..
|

| Page Properties. .. P

& | Font...

% ! Hyperlink. ..

4

3. From the 'Page Properties' menu, navigate to the 'Formatting' tab and click

4. Click on the pulldown menu on 'Background' and then click on a color you want for the background
Then click on 'OK'
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Page Properties

General | Formatting l.ﬁ.dvanced || Cuskam || Language
Background

[]Background pickure

| Make it a watermark

| | Browse. .. | Properties... |

Colors

Background: | ] V’| Hyperlink: | [ Aukomatic V|

Teuk: | ]  Aukomatic

Standard Colors: ;

= hvperlink: | || Automatic b
H_  AEEEERN | -
(IEEEDEER

Custom Colors, .,

hyperlink: | [1 autamatic ‘V|

B More Colars. ..

ik J [ Cancel

5. The entire 'bio.htm' page changes to that color

Go to 'File' > 'Save' to save the changes to your folder automatically

Close Site

ld save . coies
I Save 55..".‘\&'

Click the 'Preview in Browser' icon on the toolbar to open a new window

T | preview in Microsoft Tnternet Explarer Eu.IZIE

. This will allow you to view what your page will look like on the Internet
Use this option often to check your progress as you build your site
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2} Sabrina's Autobiography Page - Microsoft Internet Explorer |Z||E|E|
Fle Edit Wiew Favortes Tools  Help «ff

£ Back I'\J] x| & E-_"h jl:j Search ‘w:'{ntg’ Favarites
o oy b =
3 ; % 7 5 z 3 o =
Address !@ C:\Documents and Setkings | Go  Links Markorn Antivinas 3

Ggﬁglev ] :_J i Searchweb - '@Serz:'c" Site Z

>

@ Done I ﬂ My Camputer

top | steps

Step Five

In this step you will choose a table size and modify the properties of the table.
1. Click on the 'Insert Table' icon in the toolbar

ﬁé.r:é- Frames  Window Heh:i

b,
i
E
5
2
i
E

2. Highlight the number of cells you want to appear in your table and click

Tat»le* Eata Frames ‘-.-':-'D'rdaw He}p

AR A e ru~|%@ﬁﬂﬁ,1%|d a
W
W —

|

4 by 1 Table

3. Right click on your new table to open the menu and click on 'Table Properties'
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Cuk

Copy

2% Paste

“=| Inserk Rows

Insert Colurmns

& solit cells

Cpen Page in Mew Window
Miove Split

%% Manage Editable Regions. ..

Cell Properties. ..

Table Properties. ., .

: Page Propetties...

A | Font...
%; Hyperlink. ..

4. The 'Table Properties' window allows you to change the size, alignment, width, cell spacing, border size
and

color, and background color of the table. Experiment to get the look you want by clicking 'OK".

Some things to note:

keep width of your table below 800 pixels to avoid horizontal scrolling on a monitor with 800 x 600 resolution

'Cell padding' and 'Cell spacing' refer to the distance (in pixels) text and images will appear from the border

|ce|| padding/spacing of one... |ce|l padding/spacing of five...
| |
this is 1 pixel this is 5 pixels

a border of zero will show a dashed line on the 'Split' view but no border on the 'Preview' view

border of zero... border of one... border of five...

|
-
—
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Here is a sample layout...

Table Properties

Lavout Tools -
) Enable lavaut kools
() Disable layout kools
() Autematically enable layout tools based on table content
Size - =
Fows: |4 % Calumns: 1 i
Layauk - =
Alignment: ECenter R | Specify width:
T In pixels
Float: |Default v| [0 | @mp
: {11In percent
el padding: 55 iy [ 5pecify height:
) P [ In pixels
Cell spacing: 9 | = (@ | )
= = = In pErcent
Borders
— 1
Size: il:l o Light barder: | [ Aukamatic Vi
Colar: | % | Dark border: | || Automatic b
1 1 1 I
[ ]oliapse kable border
Background —
Colar; || 1] V!
[use background picture
| | [ Erowse, ., Properties. ..
Sek
[]5et as default For new tables
Skyle... (4 % [ Zancel ] [ Apply

top | steps
Step Six

In this step, you will learn how to modify individual cells in your table.

1. Right click on the cell you want to modify and on the menu click on 'Cell Properties’

W3HUB PTE LTD Page 9 2/24/2006



CuE

&

1

R

Paste

Insert Rows
Insert Columns

Split Cells. ..

Dpen Page in New Windoi
Mowe Split

Manage Editable Regions, ..

Zell Propetties. ..

A
o

I,
Table Properties... My

Page Properties. ..

Fonk...

Hyperlink. ..

2. The 'Cell Properties' window allows you to modify many parts of individual cells.
Use the pulldown menus to experiment with the look of the cells

A thing to note...

'Alignment' determines where in the cell font and graphics will appear

Here is an example of a layout...

Cell Properties

Layouk - =

Horizonkal aligriment: ECenter VJ [ 5pecify width:

Wertical alignment: | Default w | !::: |
Rows spanned: [

Columns sparined:

[ ]5pecify height:

[ Header cell
|:|N|:| wrap
Borders -
Ciolor: | — ﬂ Light border: | [ ] Aukarnatic \;i
Dark border: | | .ﬁ.utumatic-_V]
Backaround - —
Calar: | v

[JUse background pickare

| | [ Browse. .. ] Froperties. ..

N
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3. You may also merge the cell by highlighting the cells you want to merge into one
Right click to bring up the 'Merge Cells' command and select it

g Cut

=5 Copy

.ﬁ Paske

jﬂ'-‘. Insert Rows

& Insert Columngs

F* Delete Cells

|_-|j Merge Cells .

B Split Cells. . vh
Cpen Page in Mew Window
Maove Split

fé.l Manage Editable Regions. .,
Cell Properties. ..
Table Properties. ..
Page Properties, .

A | Font...

4. Or split an individual cell into rows and columns by right clicking on the cell to bring up the menu
Select 'Split Cells..."
fa Cut
S Sopy
34 Paste

5 Insert Rows

& Insert Columng
|ﬂ split Cells.... 1.,
Cpen Page inlh\"ew Sind o

Move Split

Manage Editable Regions. ..

ffit

Cell Properties. ..
Table Properties. ..

Page Properties. ..

Fontk...

% >

| Hwperlink. ..

and then choose whether you want 'rows' or 'columns' and the number
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Split Cells

3 split inko columns
) Split inkao rows

Murmber of rows:

Step Seven

Split Cells

(= split inko calumns
{7 Split inko rows

Mumnber of colurmns:

[ (84 kj[ Cancel ]

top | steps

In this step you will learn how to modify the font.

1. Highlight the font you want to change

2. Use any combination of the characteristics below

a. Change the font type by clicking on the pulldown arrow next to the font type

';E:ieu Ed@f iew Insert ﬁg{:rﬂat Tools: 1

Do ad ) Pgld s

Myriad Seh -3 (12p) - | B
T JUSTICE Mﬁt}%{q

T Kristwen ITC

T Latha

* Lucida Console
% Lucida Sans

% Lucida Sans Typewrite
H Lucida Sans Unicode

% Maiandra GO

B MANDELA ABGIER O]
T Mangal

T Marlett 0 W D_hJD . D(_\
B MATISSEAT(

b. Change the font size by either clicking on the pulldown arrow to select a number
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or clicking on the 'A' icons on the toolbar to make the font larger or smaller

windaw  Help Windove  Help
lf]v"-"“ﬂ:jf:[ ,J,rﬂjﬁ&

|.A|::::§ 1= i= = 8
Increase Fonkt Sizel— — Decrease Fort Slze|—

5

c. Change the font color by clicking on the 'Font Color' selector icon and choosing your color

HEIEEIR A

| [ | Sutormatic |

Standard Colors
H  AEENND
iy ECEENR

Cuskom Colors

Document Colors

Mare Calars...

top | steps
Step Eight

In this step you will insert and modify graphics you find on Google.

Warning: Many sites on the Internet contain copyrighted graphics, so try to choose your images from sites
that are copyright free.

1. Right click on the image you want to insert into your document to pull up the menu
Click 'Save Picture As...'
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E-mail Pickure, .. !
Prink Picture, ..
o ko My Pictures

Set as Background
Set as Desktop Ikem...

Lt
Copy

“opy Shorkouk

Add to Favarites...

Properties

2. Save the picture in your 'biography' folder on your desktop

Save Picture

Save in | 55D e _'J L £ '

ky Recent
Drocumerits

Deszktop

ty Documents

Sabring's
Cormputer

-

¢ i

My Metwork  File name: jsunflnwers :j Save
Places
Save a3 hype: ]GIF [*.qif] _vj Caricel ]
g

3. Click on the location you want the graphic on your page
Go to 'Insert' > 'Picture' > 'From File...'
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Insert | Format  Tocls Table Data  Frames Window Help

Break...
Haorizontal Line
fj‘«f Lawer
I Inling Frame
Date and Time...
Symbal...

i Comrent. .

TR AN !

s i=
= A A iz
A A LIS

=]
yl
I

plim="center"=snbsp p-
FeSunflowers! </ fontsC /o

Masigation...
Page Banner, ..

"lﬁ Web Component, ..

Database 3
Form ]
| Picture >| & : Clip &t
'{?5 Inkeractive Butkon... Eram File. .. M

File...

Bookmark. .. Chrl+G

. Hyperlink. .. Zhrl+E

. From Scanner Dr@amera. %

Mew Photo Gallary, ..

S S

Maovie in-Flash Format. ..

Mewe Drawing

B

Autoshapes
| lordart, .

(S

| Yideo...

4. Navigate to your picture and select it

Click 'Insert’
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Picture

Loak in: | == biography

My Recent
Docurments

My Documents

My Complter

i File name:
Iy Metwork,

Insert . (=

|
|

Places Files of bvpe: | all pictures
i

5. An example of the finished result

Sunflowers!l!

Zancel

6. You may modify the picture by clicking on it and using the various tools on the 'Picture Toolbar'

S h)d oS LA LA = Y
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7. An example of the finished result

top | steps
Step Nine

In this step you will create hyperlinks.
There are three types of hyperlinks:
links to outside websites
links to other pages in your website
links to places within the same document

To link to an outside website (opens in a new window)

1. Highlight the text or graphic you want to link to an outside site

click B&fd to go to Google

2. Click on the 'Hyperlink' icon on the toolbar to open the 'Insert Hyperlink' window

|2 |

3. Select the 'Target Frame...' button
Select 'New Window'
Click 'OK'
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3.

4. The word is now linked

Target Frame

Current frames page

(nong)

Target sekking

Coamron targets

Page Default {none)
Same Frame

‘i'hiole F‘aﬁe

Parent Frame

|_I:|Iank

[]5et as page default

[ K, N[ Cancel ]

In the 'Insert Hyperlink' window, make sure 'Existing File or Web Page' is selected
Type in the full URL of the outside site in the 'Address' window

Click 'OK'

Insert Hyperlink

Link to:

Existing File ar
\Web Page

Place in This
Document

T
Create MNew
Dacurient

@

E-mnail Address

Texk to display: !here |

ScreenTip. ..

Look in: ) biography V|
&1 bio.htrn (open) Bookmark. ..
Current CADocuments and SektingstCwner\Deskiopifronkpage2003_ky
Folder .
; b Target Frame...
@ sunflowers
Pages
Style...
Recent
Files
fddress: |http:,fp'www.gu:u:ugle.cu:um L7 '
[ (84 ] [ Cancel

Link to other pages in your website

1. Go to 'File' > 'New..." and select 'Blank page' from the menu that appears
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%] Microsoft FrontPage

File: Eai.'tﬁ 'ile i_‘:n_s_erb.

O e,

i New b

g

& Cpen... a3 Chrl4-0

New page
Close |} Blank pa
¥= Opensite... 5] Tesxt file

2. Use the steps outlined in Step 3 to name and save the page

3. Highlight the text you want to link to the new page
click FEr8 to go to
page 3

4. Click on the 'Hyperlink' icon on the toolbar

18]

5. Make sure you select the 'Existing File or Web Page' icon in the 'Hyperlink' window
Navigate to your 'biography' folder on the desktop and select the proper .htm page
Do not select 'Target Frame...' > 'New Window' as you did in the previous example
Click 'OK'

Insert Hyperlink

Link; ka: Texk to display: ihere | ScreenTip. ..
i Look in: i) biography w| . E
Exisking File ar = - .
Weh Page bio. bt {open) Bookmark. ..
Current i\ Docurments and Settings|Owner Deskioptfrontpage2003_ky
_ Folder
i page_three htm {open) Target Frame. .,
Flace in This bio
Pages | & sunflowers
'ij Skyle...
Create Mew Recent
Document Files
= Address: [page_three.hi:m b :
E-mail &ddress
[ OF ’ Zancel
I

6. The word is now linked

Linking to a place within the same document
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1. Click the cursor to the place in your document to which you want to navigate

2. Go to 'Insert' > 'Bookmark' and click

Insert | Format  Tools  Tabl

Break. ..

Horizontal Line
E]‘: Laver

Inline Frame

Date-and Time, ..

Symbal..,

Comment. ..

b

Mawigation...
=

Page Banmer. ..

F@l web Component..,

Database b
Farm 3
Picture 4

C;:E_ Interactive Buttan, ..

File...

| Bookmark. .. I\CtrI+G |
@3{ Hyperlink. .. lA'S(Zl:rl+l<

3. A 'Bookmark' window will appear, name your bookmark
(In this case, I want to navigate from the bottom to the top of my page, so I named mine 'top')
Click 'OK'

Bookmark

Baokmark nane:

Dther bookmarks on this page:

L=l RN}

[ Ok, L%‘J [ Cancel

4. Atiny 'flag' appears, representing a bookmark
(This flag will not appear when viewed in the browser)
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AThis is the top of my document

5. Highlight the text or image in your page from which you wish to navigate
(In this case, I highlighted 'top' since I am wanting to navigate from bottom to top)

return to f00

6. Click on the 'Hyperlink' icon and choose 'Place in This Document' and the name of the bookmark
Click 'OK'

Insert Hyperlink

Link ka; Texk to display: itu:up | ScreenTip. ..

L@ Select a place in this document:
Existing File ar = Bookmarks
Weh Page c:

= Target Frame. ..

Place in This

Dacurient

-'J Skwle, ..
Create MNew
Docurnenk

E-mail Address
' I (] D l Cancel
-_ Py -

7. The area you highlighted is now linked to the bookmark
You may now 'jump' from one area to another within the same page

top | steps

Step Ten

In this final step you will assemble a webpage using all you have learned.

Time to put your FrontPage skills to work!
Create an autobiographical webpage with the components listed below:

» at least one table that has been modified to reflect your personal choice of alignment and color
» at least two examples of modified fonts

+ at least two graphics that have been saved and modified by using the picture toolbar

« at least two hyperlinks that navigate within the webpage

« at least two hyperlinks that link to outside sites and open in a new window

top | steps
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